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Introduction 

What is Excel?  

 Excel is a spreadsheet program.  

 Spreadsheets are very useful to create and handle information data for business documents like 

financial statements and expense reports, personal documents like budgets, or shopping lists, and 

scientific data like experimental observations and medical charts. 

  Spreadsheet programs allow the user to create, edit, and analyze data that is organized into lists or 

tables.  

 With Excel, the user can:  

 perform calculations 

 analyze data  

 create colorful charts to attractively present data results 

Microsoft Excel Environment 
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Excel Basics 

Workbooks & Worksheets 
 

An excel file is also known as a workbook. A worksheet is always stored in a workbook. 

 

A worksheet or a spreadsheet is a grid of cells where you type your information, functions, and 

formulas. In other words it is your workspace. Excel’s grid divides your worksheet into rows and 

columns. The smallest unit in your worksheet is the cell. A cell is the intersection of a row and a 

column. Cells are identified by a column heading followed by the row number. For example B4 is the 

address of a cell in column B and row 4.  

By default, Microsoft Office Excel provides three worksheets.   You can insert additional worksheets 

(and other types of sheets, such as a chart sheet, macro sheet, or dialog sheet) or delete them as 

needed.   

 

 

Insert Worksheets 

 

Insert How? 

one worksheet at the end of 
the existing worksheets 

Click the Insert Worksheet tab at the bottom of the screen. 

 

One worksheet before an 
existing worksheet 

Select that worksheet, and then on the Home tab, in the Cells 
group, click Insert, and then click Insert Sheet. 

OR 

Right-click the tab of an existing worksheet, and then click 
Insert. On the General tab, click Worksheet, and then click 
OK. 

Multiple worksheets at once 
1. Hold down SHIFT, and then select the same number of 

existing sheet tabs of the worksheets that you want to 
insert in the open workbook.  

2. On the Home tab, in the Cells group, click Insert, and 
then click Insert Sheet. 

 

javascript:AppendPopup(this,'xldefWorksheet_1')
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Rename Worksheets 

On the Home tab, in the Cells group, click the arrow next to Format, and then under the Organize 

Sheets click Rename Sheet and type a new name.  

OR 

On the Sheet tab bar, right-click the sheet tab that you want to rename, click Rename, and then type 

the new name.  

 

Hide or Unhide Worksheets 

To hide a worksheet, right-click the sheet tab that worksheet, and then click hide. 

 

To unhide a worksheet, right-click on any sheet tab within the workbook, click unhide, and then 

select the name of the worksheet you want to unhide from the list of hidden worksheets. 

 

Delete Worksheets 

On the Home tab, in the Cells group, click the arrow next to Delete, and then click Delete Sheet.  

OR 

Right-click the sheet tab of the worksheet that you want to delete, and then click Delete. 

 

Move or Copy Worksheets 

On the Home tab, in the Cells group, click the arrow next to Format, and then under the Organize 

Sheets click Move or Copy Sheet.  

OR 

Right-click the sheet tab of the worksheet that you want to move or copy, and then click Move or 

Copy Sheet. 
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Selecting Cells 
The following table shows how to select cell ranges in a worksheet. 

 Select Cells, Ranges, Rows, or Columns 

 

Select How? 

A single cell Click the cell, or press the arrow keys to move to the cell. 

A range of cells Click the first cell in the range, and then drag to the last cell, 
or hold down SHIFT while you press the arrow keys to 
extend the selection. 

All cells on a worksheet 
Click the Select All button on the top left corner of the sheet. 
or press CTRL+A.  

Nonadjacent cells or cell 
ranges 

Select the first cell or range of cells, and then hold down 
CTRL while you select the other cells or ranges.  

An entire row or column Click the row or column heading.  

Adjacent rows or columns Drag across the row or column headings. Or select the first 
row or column; then hold down SHIFT while you select the 
last row or column. 

Nonadjacent rows or 
columns 

Click the column or row heading of the first row or column in 
your selection; then hold down CTRL while you click the 
column or row headings of other rows or columns that you 
want to add to the selection. 

Working With Rows and Columns 

Inserting Columns  

To insert  Step1 Step2 

a single column Select the column or a cell in the column 
immediately to the right of where you want to 
insert the new column 

On the Home tab, in the 
Cells group, click the 
arrow next to Insert, and 
then click Insert Sheet 
Columns. 

multiple 
columns 

Select the columns immediately to the right of 
where you want to insert columns. Select the 
same number of columns as you want to insert 

nonadjacent 
columns 

Hold down CTRL while you select nonadjacent 
columns. 

 

javascript:ToggleDiv('divExpCollAsst_IDA1QOUB')
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Inserting Rows  

To insert  Step1 Step2 

a single row Select the row or a cell in the row above which 
you want to insert the new row. 

On the Home tab, in the 
Cells group, click the 
arrow next to Insert, and 
then click Insert Sheet 
Columns. 

multiple rows Select the rows above which you want to 
insert rows. Select the same number of rows 
as you want to insert 

nonadjacent 
rows 

Hold down CTRL while you select nonadjacent 
rows. 

 

Hide Rows or Columns 

1. Select the rows or columns that you want to hide.  

2. Method A:  

 On the Home tab, in the Cells group, click Format.  

 Under Visibility, point to Hide & Unhide, and then click Hide Rows or Hide 

Columns.  

       OR 

Method B:  right-click a row or column (or a selection of multiple rows or columns), and then 

click Hide. 

Unhide Rows or Columns 

1. Do one of the following:  

 To display hidden rows, select the row above and below the rows that you want to 

display.  

 To display hidden columns, select the columns adjacent to either side of the columns 

that you want to display.  

 To display the first hidden row or column on a worksheet, select it by typing A1 in 

the Name Box. 

2. On the Home tab, in the Cells group, click Format.  

3. Do one of the following:  

 Under Visibility, point to Hide & Unhide, and then click Unhide Rows or Unhide 

Columns.  

 Under Cell Size, click Row Height or Column Width, and then type the value that 

you want in the Row Height or Column Width box. 
 

Delete Rows or Columns 

1. Select the rows, or columns that you want to delete.  

2. On the Home tab, in the Cells group, do one of the following:  

 To delete selected rows, click the arrow next to Delete, and then click Delete Sheet 

Rows.  

 To delete selected columns, click the arrow next to Delete, and then click Delete 

Sheet Columns.  
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Or 

3. You can also right-click a selection of cells, rows, or columns, click Delete on the shortcut 

menu, and then click the option that you want. 

 

Adjust Height of Rows or Width of Columns  

Adjust Width of 
Column(s) 

     How? 

To a specific 
value 

1. Select the row(s) or column(s) that you want to change. 
2. On the Home tab, in the Cells group, click Format.  
3. Under Cell Size, click row height or column Width.  
4. In the row height box or column width box, type the value 

that you want. 

 

To fit the contents 
(Auto Fit) 

1. Select the column(s) that you want to change.  
2. On the Home tab, in the Cells group, click Format.  
3. Under Cell Size, click AutoFit Column Width. 

OR 
double-click the column heading 

 

To the width of 
another column 

1. Select a cell in the column.  
2. On the Home tab, in the Clipboard group, click Copy, and 

then select the target column.  
3. On the Home tab, in the Clipboard group, click the arrow 

below Paste, and then click Paste Special.  
4. Under Paste, select Column widths.  

 

Note that the same applies for adjusting row heights. 

 

Delete Cells 

1. Select the cells that you want to delete.  

2. On the Home tab, in the Cells group, click the arrow next to Delete, and then click Delete 

Cells.  

3. In the Delete dialog box, click Shift cells left, Shift cells up, Entire row, or Entire column.  
 

AutoComplete & Auto fill 

Automatic Complete (Auto Complete) 

If the first few characters that you type in a cell match an existing entry in the column of that cell, 

Excel automatically enters the remaining characters for you. This is called AutoComplete. 
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 Automatic Complete works with entries containing text or a combination of text and 

numbers. Entries that contain only numbers, dates, or times are not automatically 

completed. 

 No empty cells between the values. 
 

Automatic Complete Using pick from list 

When the text values are too long or the first few letters are similar, it is more convenient to using 

auto complete through pick from list. How? 

 

 Right click on the cell >> then choose pick from list 

Automatic Fill (AutoFill) 

You can drag the fill handle, or  use the Fill command On the Home tab, in the Editing group to fill 

the active cell or a selected range with the contents of an adjacent cell or range. This is called 

AutoFill.  

Automatic Fill (AutoFill) Using the Fill Handle 

The fill handle allows you to do different things depending on the type of entry in cells. Into adjacent 

cells, you can fill:  

 data (with different  auto fill options like copy, fill with or without formatting, …) 

 formulas 

 a series of numbers 

 dates 

 built-in series items 

 custom series items 

To choose how you want to fill the selection, click Auto Fill Options, and then click the option that you 

want. Note that if you drag the fill handle up or to the left of a selection and stop in the selected cells 

without going past the first column or the top row in the selection, Excel deletes the data within the 

selection. You must drag the fill handle out of the selected area before releasing the mouse button. 

A quick way, other than using the fill handle, to automatically fill a formula downward, for all adjacent 
cells that it applies to, is to double-click the fill handle of the first cell that contains the formula. 

Fill in a series of numbers, dates, or other built-in series items 

Using the fill handle, you can quickly fill cells in a range with a series of numbers or dates or with a built-

in series for days, weekdays, months, or years. 

1. Type the starting value for the series in a cell, and  a value in the next cell to establish a 

pattern. For example, if you want the series 1, 2, 3, 4, 5..., type 1 and 2 in the first two cells. 

If you want the series 2, 4, 6, 8..., type 2 and 4. If you want the series 2, 2, 2, 2..., you can 

leave the second cell blank. 

2. Select the cell or cells that contain the starting values.  

3. Drag the fill handle across the range that you want to fill.  

4. To fill in increasing order, drag down or to the right. To fill in decreasing order, drag up or to 

the left. 

 

javascript:AppendPopup(this,'XldefFillHandle_3')
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Custom Fill Series or Custom Lists 

 A custom or user defined fill series can be based on a list of existing items on a worksheet, or you can 

type the list from scratch.  

  

Creating a custom list based on an existing list of items 

1. On the worksheet, select the list of items that you want to use in the fill series.  

2. Click the Microsoft Office Button, and then click Excel Options.  

3. Click Popular, and then under Top options for working with Excel, click Edit Custom Lists.  

4. Verify that the cell reference of the list of items that you selected is displayed in the Import 

list from cells box, and then click Import.  

5. The items in the list that you selected are added to the Custom lists box. 

 

Creating a custom fill series based on a new list of items 

1. Click the Microsoft Office Button, and then click Excel Options.  

2. Click Popular, and then under Top options for working with Excel, click Edit Custom Lists.  

3. In the Custom lists box, click NEW LIST, and then type the entries in the List entries box, 

beginning with the first entry.  

4. Press ENTER after each entry, or type the entries separated by a comma. 

5. When the list is complete, click Add, and then click OK twice.  

Formatting  

Formatting Cells 

Editing cells allows you to enter data, formulas, or functions on your spreadsheet. However, it doesn’t 

give your spreadsheet the elegant 

professional look that formatting 

does.  

Formatting allows you to change 

the look of your entries, their 

alignment, shading… 

 

Format Cells dialog box 

In order to format cells, on the 

Home tab, in the Cells group, click 

the arrow next to Format, and then 

Use the Format Cells dialog box 

to format the contents of selected 

cells. The format cells dialog box 

has six tabs as seen in the 

following dialog box: 
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The following table summarizes options that can be made from various tabs in the Format Cell Dialog 

Box. 

 

Format Cell Dialog Box Tab Options  

Number  The selection of a suitable data type from the categories listed on this tab.  

 If the cell contains text and number, select General. 

 If the cell contains a number that will be included in functions or formulas, 
select any numerical category. 

Alignment The selection of the position and alignment of the data within cells. 

Font The selection of Font attributes including font name, size, style, and effects. 

Border The addition of borders 

Fill  The addition of shading and background color to cells. 

Protection  The protection or hiding of a certain cell in your worksheet 

 

Cell Styles 

 A cell style is a defined set of formatting characteristics, such as fonts and font sizes, number formats, 

cell borders, and cell shading. Excel 2010 allows the user to use built in styles that can change with 

themes, or customized styles.  

Why should you use cell styles? Why not only regular formats?  The answer to these questions is that if 

you want to apply several formats in one step, and ensure that cells have consistent formatting, you can 

use a cell style. To prevent anyone from making changes to specific cells, you can also use a cell style 

that locks cells. 

 

Working With Cell Styles How 

Apply a cell style 
 

1. Select the cells that you want to format.  
2. On the Home tab, in the Styles group, click Cell Styles.  
3. Click the cell style that you want to apply.  

 
Create a custom cell style 
 

1. On the Home tab, in the Styles group, click Cell Styles.  
2. Click New Cell Style.  
3. In the Style name box, type an appropriate name for the new cell 

style.  
4. Click Format.  
5. On the various tabs in the Format Cells dialog box, select the 

formatting that you want, and then click OK.  
6. In the Style dialog box, under Style Includes (By Example), clear the 

check boxes for any formatting that you don't want to include in the 
cell style.  

javascript:AppendPopup(this,'offont_1')


Microsoft Excel 2010 Handout 0 

 

 P a g e  | 13 

 

 

Remove a cell style 
 

1. To remove a cell style from selected cells without deleting the cell 
style, select the cells that are formatted with that cell style.  

2. On the Home tab, in the Styles group, click Cell Styles.  
3. Do one of the following:  

 To remove the cell style from the selected cells without deleting 
the cell style, under Good, Bad, and Neutral, click Normal.  

 To delete the cell style and remove it from all cells that are 
formatted with it, right-click the cell style, and then click Delete. 

 

Create a cell style by 
modifying an existing cell 
style 
 

1. On the Home tab, in the Styles group, click Cell Styles.  
2. Do one of the following:  

 To modify an existing cell style, right-click that cell style, and then 
click Modify.  

 To create a duplicate of an existing cell style, right-click that cell 
style, and then click Duplicate. 

 In the Style name box, type an appropriate name for the new cell 
style.  

  

 

Automatic Table Format (Auto Format) 

Microsoft Office Excel 2010 provides numerous predefined table styles (or quick styles) that can be used 

to quickly format a table. You can choose a table style when you create a table, or apply a table style to an 

existing table. 

1. On the worksheet, select a range of cells that you want to quickly format as a table.  

2. On the Home tab, in the Styles group, click Format as Table.  

3. Under Light, Medium, or Dark, click the table style that you want to use.  

 

Note Custom table styles are available under Custom after you create one or more of them. You can use 

Excel’s Help to learn more about Create or delete a custom table 

Choose table style options to format the table elements 

1. On the worksheet, select the table to which you want to apply table style options.  

This displays the Table Tools, adding a Design tab. 

2. On the Design tab, in the Table Style Options group, do one of the following:  

 To turn the header row on or off, select or clear the Header Row check box.  

 To turn the totals row on or off, select or clear the Totals Row check box.  

 To display special formatting for the first column of the table, select the First Column 

check box.  

 To display special formatting for the last column of the table, select the Last Column 

check box.  

 To display odd and even rows differently for ease of reading, select the Banded Rows 

check box.  

 To display odd and even columns differently for ease of reading, select the Banded 

Columns check box. 
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